• 设为首页
  • 点击收藏
  • 手机版
    手机扫一扫访问
    迪恩网络手机版
  • 关注官方公众号
    微信扫一扫关注
    迪恩网络公众号

[C++]3-1得分(ScoreACM-ICPCSeoul2005,UVa1585)

原作者: [db:作者] 来自: [db:来源] 收藏 邀请

Question

习题3-1 得分(Score ACM-ICPC Seoul 2005,UVa1585)

题目:给出一个由O和X组成的串(长度为1~80),统计得分。
每个O的分数为目前连续出现的O的个数,X的得分为0。
例如:OOXXOXXOOO的得分为1+2+0+0+1+0+0+1+2+3。

 

Description
There is an objective test result such as OOXXOXXOOO. An `O' means a correct answer of a problem and an `X' means a wrong answer. The score of each problem of this test is calculated by itself and its just previous consecutive `O's only when the answer is correct. For example, the score of the 10th problem is 3 that is obtained by itself and its two previous consecutive `O's.
Therefore, the score ofOOXXOXXOOO” is 10 which is calculated by `1+2+0+0+1+0+0+1+2+3.
You are to write a program calculating the scores of test results.

 

Input
Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case starts with a line containing a string composed by O’ and X' and the length of the string is more than 0 and less than 80. There is no spaces between O’ and ` X’.

 

Output
Your program is to write to standard output. Print exactly one line for each test case. The line is to contain the score of the test case.
The following shows sample input and output for five test cases.

 

Sample Input
5
OOXXOXXOOO
OOXXOOXXOO
OXOXOXOXOXOXOX
OOOOOOOOOO
OOOOXOOOOXOOOOX

 

Sample Output
10
9
7
55
30

Think

  简单题。略。

Code

/*
    习题3-1 得分(Score ACM-ICPC Seoul 2005,UVa1585)

    题目:给出一个由O和X组成的串(长度为1~80),统计得分。
        每个O的分数为目前连续出现的O的个数,X的得分为0。
        例如:OOXXOXXOOO的得分为1+2+0+0+1+0+0+1+2+3。
*/
#include<iostream>
#include<string.h>
using namespace std;

const int maxn = 85;
char str[maxn];

int main(){
    int n,sum;
    int prev;//记录前面累加的和
    scanf("%d", &n);
    while(n--){
        scanf("%s", &str);
        sum = prev = 0;//默认累计为0
        for(int i=0,len = strlen(str);i<len;i++){
            if(str[i] == 'O'){
                prev++;
                sum += prev;
            } else {
                prev = 0;
            }
        }
        printf("%d\n", sum);
    }
    return 0;
}

  


鲜花

握手

雷人

路过

鸡蛋
该文章已有0人参与评论

请发表评论

全部评论

专题导读
上一篇:
C++构造函数后加冒号发布时间:2022-07-13
下一篇:
C#预处理器指令发布时间:2022-07-13
热门推荐
阅读排行榜

扫描微信二维码

查看手机版网站

随时了解更新最新资讯

139-2527-9053

在线客服(服务时间 9:00~18:00)

在线QQ客服
地址:深圳市南山区西丽大学城创智工业园
电邮:jeky_zhao#qq.com
移动电话:139-2527-9053

Powered by 互联科技 X3.4© 2001-2213 极客世界.|Sitemap